Unbuntu+Eclipse+Subversion

I got mine working. It was not easy or obvious and it took a fair bit of searching to find the right combination. Under Windows this is easy because there are no choices (well, no obvious ones to me). Under Linux you have to know more about what is going on and there is a lot to know. My approach to these things is to find out just enough to get it working. I have a lot of hard problems to solve, I don’t want anymore, I just want this to work.

Under Windows I thought I just installed Subversion, actually I think someone set it up and put it all in a zip file which is what I loaded. That all just worked. So I took a closer look at my Windows system.

There is a plugin called Subversive from polarion. It depends on a connector called JavaHL which is a Win32 binary file, so no use under Linux. Okay, so I need to do something different. Googling revealed another product called Subclipse which is (I think) from Tigris who also do the Subversion server. Got that? Three products that start with ‘Sub’ easy to get mixed up here.

Both Subclipse and Subversive can use the JavaHL binary. Some people have pulled the JavaHL source and compiled it. But that seems to be no longer necessary because you can install it using the Package Manager now. I tried this, including editing the eclipse.ini file to add the special option but it did not work for me.

The other approach that both of these clients use is the SVNKit which is Java all the way down. I installed that and it works fine.

This is the list of relevant stuff in my Eclipse ‘Software Updates and Add-ons’ the Installed Software tab.

This is what my subversion page looks like in my windows->preferences:Team/SVN:SVN Connector

I have yet to find any missing features with this approach. Maybe there is a speed issue but I’m on a slow link at the moment and it is… slow, but no slower that I would expect. It handles file compare just fine, some things I read suggested some combinations of things wouldn’t do that.

The crucial urls you need (and these things seem to shift over time so this is only correct today):
http://eclipse.svnkit.com/1.2.x/
http://community.polarion.com/projects/subversive/download/eclipse/2.0/ganymede-site/

Just to be precise about versions:
Ubuntu 8.04 Hardy Heron
Eclipse 3.4

1 Comment


  1. An update: Still no loss of functionality after using it for a few days now. It generally prompts me for my password (which it remembers and fills in for me) once during a session. That is okay. For some reason under Windows the ability to do branches stopped working. I have it back now under Linux.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *